aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-rabbit
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:50:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:54:30 -0300
commitb359a2e0b163b0f737efa37e7786f79af8cf8a1b (patch)
tree838de9ec9e495143e8575fa3086a599a7617d8ff /testing/py3-rabbit
parent3e5813342e17181e5feb6704081db699ca613de2 (diff)
downloadaports-b359a2e0b163b0f737efa37e7786f79af8cf8a1b.tar.bz2
aports-b359a2e0b163b0f737efa37e7786f79af8cf8a1b.tar.xz
testing/py3-rabbit: rename from py-rabbit
Diffstat (limited to 'testing/py3-rabbit')
-rw-r--r--testing/py3-rabbit/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-rabbit/APKBUILD b/testing/py3-rabbit/APKBUILD
new file mode 100644
index 0000000000..d713e0f6dd
--- /dev/null
+++ b/testing/py3-rabbit/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-rabbit
+_pkgname=pyrabbit
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="A Pythonic interface to the RabbitMQ Management HTTP API"
+url="https://github.com/bkjones/pyrabbit"
+arch="noarch"
+license="MIT"
+depends="python2 py-httplib2"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="625013ba47fe79d296b76a74200c3312 pyrabbit-1.1.0.tar.gz"
+sha256sums="50b8995fbfde14820ddc97292312c8f0c77054748c2b018138d03d94e400c39c pyrabbit-1.1.0.tar.gz"
+sha512sums="aa18c3ad232840da9b4978e275c05a82ea75212f3c4ee2df68075ac93295d9448a2376656953e7d1d9c9bc6a7e759eef020a8aaef98491a12959a416c31187ad pyrabbit-1.1.0.tar.gz"