aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-readchar
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-12 15:48:36 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-12 18:14:36 +0100
commitfb629585fece9d7051db690f07fb9359ba114772 (patch)
tree1e2700407a6529cfc28d4dd53f611dab8eaab7e4 /testing/py3-readchar
parenta69c42f34dcb3832efb6b0dc3e07e2aea167a27a (diff)
downloadaports-fb629585fece9d7051db690f07fb9359ba114772.tar.bz2
aports-fb629585fece9d7051db690f07fb9359ba114772.tar.xz
testing/py3-readchar: new aport
https://github.com/magmax/python-readchar Python library to read characters and key strokes
Diffstat (limited to 'testing/py3-readchar')
-rw-r--r--testing/py3-readchar/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-readchar/APKBUILD b/testing/py3-readchar/APKBUILD
new file mode 100644
index 0000000000..a4ced0694e
--- /dev/null
+++ b/testing/py3-readchar/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-readchar
+pkgver=2.0.0
+pkgrel=0
+pkgdesc=" Python library to read characters and key strokes"
+url="https://github.com/magmax/python-readchar"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pexpect py3-coverage py3-pytest py3-pytest-cov py3-wheel"
+source="https://github.com/magmax/python-readchar/archive/$pkgver/py3-readchar-$pkgver.tar.gz"
+builddir="$srcdir/python-readchar-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ # Remove installed tests
+ rm -r "$pkgdir"/usr/lib/python*/site-packages/tests
+}
+
+sha512sums="92331e55080f5ebf55e313bd0e9562d55578df98ee116fa534a2ae47b43cbd9b19cf11263db821490a6b9ae5f62b78d378fd5b4c996d98a88c765af489b4d70f py3-readchar-2.0.0.tar.gz"