aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-recommonmark/APKBUILD
diff options
context:
space:
mode:
authorRobert Sacks <robert@sacks.email>2019-07-05 21:33:00 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 17:57:03 +0100
commitde7419581bd229c5d25925039513fd3d7dd5ced7 (patch)
treebcb022c944607e23312f5ee54fb5b471221581b2 /testing/py3-recommonmark/APKBUILD
parent7c76b6bce144556262b8fca23b528e428429b787 (diff)
downloadaports-de7419581bd229c5d25925039513fd3d7dd5ced7.tar.bz2
aports-de7419581bd229c5d25925039513fd3d7dd5ced7.tar.xz
testing/py3-recommonmark: new aport
https://github.com/readthedocs/recommonmark A docutils-compatibility bridge to CommonMark
Diffstat (limited to 'testing/py3-recommonmark/APKBUILD')
-rw-r--r--testing/py3-recommonmark/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-recommonmark/APKBUILD b/testing/py3-recommonmark/APKBUILD
new file mode 100644
index 0000000000..e668124518
--- /dev/null
+++ b/testing/py3-recommonmark/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Robert Sacks <robert@sacks.email>
+# Maintainer: Robert Sacks <robert@sacks.email>
+pkgname=py3-recommonmark
+_pyname=recommonmark
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A docutils-compatibility bridge to CommonMark"
+url="https://github.com/readthedocs/recommonmark"
+arch="noarch"
+license="MIT"
+depends="python3 py3-commonmark py3-docutils py3-sphinx"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="$_pyname-$pkgver.tar.gz::https://github.com/readthedocs/$_pyname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ rm -f tests/test_sphinx.py
+ pytest-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e11a86961e477e9ae258df90c666fd0129a0ae858a8d5399b7f768b9e9ec5b4952ef5f9383ea91d8ccb1379e2753151387f7250588a98f43929bf3ebe78b7df9 recommonmark-0.5.0.tar.gz"