aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-redmine
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 12:33:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 12:33:20 -0300
commit8b01a0261a7c5c92d9309efdbb5bf31fbb4a68e0 (patch)
tree8bffd94e7c071f7385938d0b650658043e8783eb /testing/py3-redmine
parent28dd570bb463e4eea9cee264168bb794ecd2e48e (diff)
downloadaports-8b01a0261a7c5c92d9309efdbb5bf31fbb4a68e0.tar.bz2
aports-8b01a0261a7c5c92d9309efdbb5bf31fbb4a68e0.tar.xz
testing/py3-redmine: drop py2
Diffstat (limited to 'testing/py3-redmine')
-rw-r--r--testing/py3-redmine/APKBUILD38
1 files changed, 10 insertions, 28 deletions
diff --git a/testing/py3-redmine/APKBUILD b/testing/py3-redmine/APKBUILD
index e9fc2afe92..3bacb6c708 100644
--- a/testing/py3-redmine/APKBUILD
+++ b/testing/py3-redmine/APKBUILD
@@ -1,50 +1,32 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-redmine
+pkgname=py3-redmine
_pkgname=python-redmine
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="A simple library for communicating with redmine"
url="https://github.com/maxtepkeev/python-redmine"
arch="noarch"
license="Apache-2.0"
-depends="python2 py-requests"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+depends="python3 py3-requests"
+makedepends="py3-setuptools"
+checkdepends="py3-nose"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-redmine" # Backwards compatibility
+provides="py-redmine=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
+ nosetests
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
- replaces="$pkgname"
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3f8e11315e8e2b4474e8b981bd801ef75857fe73e8ed18d27f64223703d18ea2061416ed38ea35c4a4460a4ccba167b41ab48e2489930181951e9e2a5f53ec12 python-redmine-2.0.2.tar.gz"