aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-rss2email
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-11-26 17:47:54 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-26 18:04:41 +0100
commit1b4d507c1b14acd529200cdd895b6d5a30d2efec (patch)
tree170a67cbaf424d24ba374aaf7bd62e8e92ffb599 /testing/py3-rss2email
parentbae061751f86a8a22305ea1935006d4bf4385ca8 (diff)
downloadaports-1b4d507c1b14acd529200cdd895b6d5a30d2efec.tar.bz2
aports-1b4d507c1b14acd529200cdd895b6d5a30d2efec.tar.xz
testing/py3-rss2email: new aport
https://github.com/rss2email/rss2email Forward RSS feeds to your email address, community maintained
Diffstat (limited to 'testing/py3-rss2email')
-rw-r--r--testing/py3-rss2email/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-rss2email/APKBUILD b/testing/py3-rss2email/APKBUILD
new file mode 100644
index 0000000000..10664ed355
--- /dev/null
+++ b/testing/py3-rss2email/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="py3-rss2email"
+_pyname="rss2email"
+pkgver="3.11"
+pkgrel=0
+pkgdesc="Forward RSS feeds to your email address, community maintained"
+url="https://github.com/rss2email/rss2email"
+arch="noarch"
+license="GPL-2.0-only"
+depends="python3 py3-feedparser py3-html2text py3-beautifulsoup4"
+makedepends="py3-setuptools"
+source="$_pyname-$pkgver.tar.gz::https://github.com/rss2email/rss2email/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="2efdef703a4b4774d85926f500a37689aea3a324f63a13a686a2322c9f69ac7b940c5b953f417d9259e1493b3dafde4c2e1ddb3433d085fb2400cd06001141bb rss2email-3.11.tar.gz"