aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-schema
diff options
context:
space:
mode:
authorSasha Gerrand <alpine-pkgs@sgerrand.com>2019-06-18 13:12:30 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 07:25:00 -0300
commit7f4a2195be8cd9b0977010814cd8a2a9636468f8 (patch)
tree5672b154d6e9e61342b53e7d1efe817bc3e2e630 /testing/py3-schema
parent98e7b1787218ae4b0b890f8dcfa02d1f80633ffe (diff)
downloadaports-7f4a2195be8cd9b0977010814cd8a2a9636468f8.tar.bz2
aports-7f4a2195be8cd9b0977010814cd8a2a9636468f8.tar.xz
testing/py3-schema: new aport
https://github.com/keleshev/schema Schema is a library for validating Python data structures
Diffstat (limited to 'testing/py3-schema')
-rw-r--r--testing/py3-schema/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-schema/APKBUILD b/testing/py3-schema/APKBUILD
new file mode 100644
index 0000000000..731e6b5c43
--- /dev/null
+++ b/testing/py3-schema/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Sasha Gerrand <alpine-pkgs@sgerrand.com>
+# Maintainer: Sasha Gerrand <alpine-pkgs@sgerrand.com>
+pkgname=py3-schema
+_pkgname=schema
+pkgver=0.6.8
+pkgrel=0
+pkgdesc="Schema is a library for validating Python data structures"
+url="https://github.com/keleshev/$_pkgname"
+arch="noarch"
+license="MIT"
+depends="python3"
+checkdepends="pytest"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/keleshev/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH="$PWD" python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ PYTHONPATH="$PWD" python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3de2d7ef5eca8d1b333c1b8e3535d3522ddf8f416d1fb5b2e75f133ae5eb14226b1924c8c367a60381621ed55d0e626bd75fc622462badc44974ebc395929dac py3-schema-0.6.8.tar.gz"