aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-schema
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 02:49:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 04:31:50 -0300
commit1c0bb483aea61f3a718b0d28d34abeb861c00c08 (patch)
tree6c5349e44182ef2f268f6c7558dde1a5529117f5 /testing/py3-schema
parent470e2801ec43749489dad8377d3e07a938330f71 (diff)
downloadaports-1c0bb483aea61f3a718b0d28d34abeb861c00c08.tar.bz2
aports-1c0bb483aea61f3a718b0d28d34abeb861c00c08.tar.xz
testing/py3-schema: upgrade to 0.7.0
Diffstat (limited to 'testing/py3-schema')
-rw-r--r--testing/py3-schema/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/testing/py3-schema/APKBUILD b/testing/py3-schema/APKBUILD
index 731e6b5c43..31a5368b32 100644
--- a/testing/py3-schema/APKBUILD
+++ b/testing/py3-schema/APKBUILD
@@ -2,31 +2,28 @@
# Maintainer: Sasha Gerrand <alpine-pkgs@sgerrand.com>
pkgname=py3-schema
_pkgname=schema
-pkgver=0.6.8
+pkgver=0.7.0
pkgrel=0
pkgdesc="Schema is a library for validating Python data structures"
url="https://github.com/keleshev/$_pkgname"
arch="noarch"
license="MIT"
depends="python3"
-checkdepends="pytest"
+checkdepends="py3-pytest py3-mock"
makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/keleshev/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- PYTHONPATH="$PWD" python3 setup.py test
+ python3 -m pytest
}
package() {
- cd "$builddir"
PYTHONPATH="$PWD" python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="3de2d7ef5eca8d1b333c1b8e3535d3522ddf8f416d1fb5b2e75f133ae5eb14226b1924c8c367a60381621ed55d0e626bd75fc622462badc44974ebc395929dac py3-schema-0.6.8.tar.gz"
+sha512sums="2ea09f3111bcb22d70791159ca35098d230e93306d1d8ed9d44da0d8d29d740c5682620ce4b1465d9c2dfc7bd0bb50cce115393cd6d59c9a6e199381048e379e py3-schema-0.7.0.tar.gz"