aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-semantic-version
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-21 11:18:49 +0300
committerprspkt <prspkt@protonmail.com>2019-07-21 11:27:50 +0300
commite1dcce20952e1b770dcefe467b6b59162ad55853 (patch)
treee13eb932369099ab12813b9fa7d7721ea9b13f6e /testing/py3-semantic-version
parent5edf5392d86395ca64e5a443c7ae34689ed1dd66 (diff)
downloadaports-e1dcce20952e1b770dcefe467b6b59162ad55853.tar.bz2
aports-e1dcce20952e1b770dcefe467b6b59162ad55853.tar.xz
testing/py-semanticversion: drop python2
Diffstat (limited to 'testing/py3-semantic-version')
-rw-r--r--testing/py3-semantic-version/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-semantic-version/APKBUILD b/testing/py3-semantic-version/APKBUILD
new file mode 100644
index 0000000000..a8324b75e5
--- /dev/null
+++ b/testing/py3-semantic-version/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=py3-semantic-version
+pkgver=2.6.0
+pkgrel=1
+pkgdesc="A library implementing the 'SemVer' scheme."
+url="https://github.com/rbarrois/python-semanticversion"
+arch="noarch"
+license="BSD"
+depends="python3"
+makedepends="py3-setuptools"
+install=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/rbarrois/python-semanticversion/archive/v$pkgver.tar.gz"
+builddir="$srcdir/python-semanticversion-$pkgver"
+
+replaces=py-semanticversion # Backwards compatibility
+provides=py-semanticversion=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr \
+ --root="$pkgdir" --optimize=1 || return 1
+}
+
+sha512sums="18db9279c2728565b13362c54bedbf569f0878cbe6bb58e631d87ffe7cff7d9131a30a2592cbf511091c03e854851159bbb298fe7469f53e8a2d92cf26ab4d0b py3-semantic-version-2.6.0.tar.gz"