aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-seqdiag
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-06 18:39:17 +0300
committerprspkt <prspkt@protonmail.com>2019-06-06 19:12:00 +0300
commit48dbc0fdf4638e081afc4eca56388d8668cfb290 (patch)
tree007b170c04aee032d48259ab36e71feb5046c8fa /testing/py3-seqdiag
parentf24be7d935f0679721800cf7c42f0124e90023db (diff)
downloadaports-48dbc0fdf4638e081afc4eca56388d8668cfb290.tar.bz2
aports-48dbc0fdf4638e081afc4eca56388d8668cfb290.tar.xz
testing/py3-seqdiag: modernize
Diffstat (limited to 'testing/py3-seqdiag')
-rw-r--r--testing/py3-seqdiag/APKBUILD18
1 files changed, 2 insertions, 16 deletions
diff --git a/testing/py3-seqdiag/APKBUILD b/testing/py3-seqdiag/APKBUILD
index efb5d776f6..1a906807b3 100644
--- a/testing/py3-seqdiag/APKBUILD
+++ b/testing/py3-seqdiag/APKBUILD
@@ -4,7 +4,7 @@ pkgname=py3-seqdiag
_pkgname=seqdiag
pkgver=0.9.5
pkgrel=3
-pkgdesc="seqdiag generate sequence-diagram image file"
+pkgdesc="Generate sequence-diagram image file from spec-text file"
url="https://pypi.python.org/pypi/seqdiag"
arch="noarch"
license="Apache-2.0"
@@ -13,29 +13,15 @@ makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
replaces="py-seqdiag" # for backwards compatibility
provides="py-seqdiag=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="18b05be0467a23b7d8569a937d6de02b seqdiag-0.9.5.tar.gz"
-sha256sums="994402cb19fef77ee113d18810aa397a7290553cda5f900be2bb44e2c7742657 seqdiag-0.9.5.tar.gz"
sha512sums="1f7222b769937a68592d406b7fd73446bf6c2bf6b1acc7ef9814eb04359c5e12cc7084a75cb38c3d84e76bfc55ce480ae9e74d1bb2cef62a14c52dd2f59e0a7f seqdiag-0.9.5.tar.gz"