aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-serial
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 11:52:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 12:26:33 -0300
commit7d36036f99ad777549b8a7f98e18e0e9329c1e8c (patch)
tree75b3500e8337f9449f56a4be101f0ccff900b861 /testing/py3-serial
parent937cf64d27146a061452db15f5ecb1e55f2354bd (diff)
downloadaports-7d36036f99ad777549b8a7f98e18e0e9329c1e8c.tar.bz2
aports-7d36036f99ad777549b8a7f98e18e0e9329c1e8c.tar.xz
testing/py3-serial: rename from py-serial
Diffstat (limited to 'testing/py3-serial')
-rw-r--r--testing/py3-serial/APKBUILD74
1 files changed, 74 insertions, 0 deletions
diff --git a/testing/py3-serial/APKBUILD b/testing/py3-serial/APKBUILD
new file mode 100644
index 0000000000..97062d6d90
--- /dev/null
+++ b/testing/py3-serial/APKBUILD
@@ -0,0 +1,74 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-serial
+_pkgname=pyserial
+pkgver=3.4
+pkgrel=1
+pkgdesc="Python Serial Port Extension"
+url="http://pyserial.sourceforge.net/"
+arch="noarch"
+license="Python"
+depends="python2"
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3 $pkgname-doc $pkgname-examples"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ depends="py2-${pkgname#py-} py3-${pkgname#py-}"
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py_common python2
+ rm "$subpkgdir/usr/bin/miniterm.py"
+}
+
+_py3() {
+ _py_common python3
+}
+
+_py_common() {
+ local python="$1"
+ depends="$python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+doc() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/ || return 1
+ # Documentation files
+ _docs="appendix.rst examples.rst index.rst pyserial.rst \
+ pyserial_api.rst shortintro.rst tools.rst url_handlers.rst"
+ for _doc in $_docs; do
+ mv "$srcdir"/$_pkgname-$pkgver/documentation/$_doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
+ done
+}
+
+examples() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/examples || return 1
+ # Example files
+ _examples="port_publisher.sh rfc2217_server.py tcp_serial_redirect.py\
+ wxSerialConfigDialog.py wxTerminal.py port_publisher.py\
+ at_protocol.py setup-miniterm-py2exe.py\
+ setup-rfc2217_server-py2exe.py setup-wxTerminal-py2exe.py\
+ wxSerialConfigDialog.wxg wxTerminal.wxg"
+ for _example in $_examples; do
+ mv "$srcdir"/$_pkgname-$pkgver/examples/$_example \
+ "$subpkgdir"/usr/share/doc/$pkgname/examples/$_example || return 1
+ done
+}
+
+sha512sums="d71dffc330704e41caac6054adf192bee2f1c119691faf2ea93fe22e8e3ba000dc4a1434293f6f80d05a5577d85b96791f656e28d5c63fb0ce6a6605467a117f pyserial-3.4.tar.gz"