aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-shortuuid
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-08 08:01:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-08 21:46:59 -0300
commit841b9a17cc96c63e01a50fdece44a3562452d257 (patch)
treea75c12b6d39a932394cbffff408be618c9da7f27 /testing/py3-shortuuid
parent0bb8fb8d50b1764875696b9db8b5feb055e5e5b0 (diff)
downloadaports-841b9a17cc96c63e01a50fdece44a3562452d257.tar.bz2
aports-841b9a17cc96c63e01a50fdece44a3562452d257.tar.xz
testing/py3-shortuuid: upgrade to 1.0.1
Diffstat (limited to 'testing/py3-shortuuid')
-rw-r--r--testing/py3-shortuuid/APKBUILD14
-rw-r--r--testing/py3-shortuuid/fix-pep8-tests.patch38
2 files changed, 6 insertions, 46 deletions
diff --git a/testing/py3-shortuuid/APKBUILD b/testing/py3-shortuuid/APKBUILD
index 9bd2080894..4ad7a3201b 100644
--- a/testing/py3-shortuuid/APKBUILD
+++ b/testing/py3-shortuuid/APKBUILD
@@ -1,16 +1,15 @@
-# Maintainer:
+# Maintainer:
pkgname=py3-shortuuid
_pkgname=shortuuid
-pkgver=0.5.0
-pkgrel=3
+pkgver=1.0.1
+pkgrel=0
pkgdesc="Python library that generates short, pretty, unambiguous unique IDs"
url="https://pypi.python.org/pypi/shortuuid/"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- fix-pep8-tests.patch"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/shortuuid-$pkgver"
replaces="py-shortuuid" # Backwards compatibility
@@ -25,8 +24,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="bf0b804281af1a515979a104c22e0c0e5cf99fe55efe6e29bb4b4b0d1d5a78b1e83a2d0262d6c2e2c2745f5ea198153fba80718aabac2955c691e6cb9bd5f4b5 shortuuid-0.5.0.tar.gz
-ae5c0c8948006215fff591b025cb410ce434f20a0222194a15db4e7571d225a23761be3192b4427712cf3766156602195b53c00698d857cdc680664977eab813 fix-pep8-tests.patch"
+sha512sums="fd8eca4b8b944c591f51aba4fceedddf4adac7fb052a40304fff8590a535b451ffe15b48dde9164d4386be9f5ca9af824c936812bfb192991c443b20a1e38070 shortuuid-1.0.1.tar.gz"
diff --git a/testing/py3-shortuuid/fix-pep8-tests.patch b/testing/py3-shortuuid/fix-pep8-tests.patch
deleted file mode 100644
index 6e688960ab..0000000000
--- a/testing/py3-shortuuid/fix-pep8-tests.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -32,5 +32,4 @@ setup(
- classifiers=classifiers,
- packages=["shortuuid"],
- test_suite='shortuuid.tests',
-- tests_require=['pep8'],
- )
-Index: shortuuid-0.5.0/shortuuid/tests.py
-===================================================================
---- a/shortuuid/tests.py
-+++ b/shortuuid/tests.py
-@@ -2,7 +2,6 @@ import os
- import string
- import sys
- import unittest
--import pep8
- from collections import defaultdict
-
- from uuid import UUID, uuid4
-@@ -125,16 +124,6 @@ class ClassShortUUIDTest(unittest.TestCa
- su4 = ShortUUID()
- self.assertEqual(su4.encoded_length(num_bytes=8), 11)
-
-- def test_pep8(self):
-- pep8style = pep8.StyleGuide([['statistics', True],
-- ['show-sources', True],
-- ['repeat', True],
-- ['paths', [os.path.dirname(
-- os.path.abspath(__file__))]]],
-- parse_argv=False)
-- report = pep8style.check_files()
-- assert report.total_errors == 0
--
-
- class ShortUUIDPaddingTest(unittest.TestCase):
- def test_padding(self):
-