aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sip
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-18 17:27:25 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-18 18:16:07 +0000
commit3a99cf1e7285b5350c74e3ed2dda38b9c6976f92 (patch)
treeab8f35068f105d9f705125fc944b6aacc6511f89 /testing/py3-sip
parent1c2cae4c85f97ed37f4384e6025cdb7da96a4ec4 (diff)
downloadaports-3a99cf1e7285b5350c74e3ed2dda38b9c6976f92.tar.bz2
aports-3a99cf1e7285b5350c74e3ed2dda38b9c6976f92.tar.xz
testing/py3-sip: new aport
Diffstat (limited to 'testing/py3-sip')
-rw-r--r--testing/py3-sip/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py3-sip/APKBUILD b/testing/py3-sip/APKBUILD
new file mode 100644
index 0000000000..796dc5ae8a
--- /dev/null
+++ b/testing/py3-sip/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-sip
+_pkgname=sip
+pkgver=4.18
+pkgrel=0
+pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries. Python 3 package."
+url="http://www.riverbankcomputing.com/software/sip/"
+arch="all"
+license="custom:sip"
+depends=""
+depends_dev=""
+makedepends="python3-dev"
+install=""
+replaces="py-sip"
+subpackages="$pkgname-dev"
+source="http://sourceforge.net/projects/pyqt/files/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
+ python3 configure.py
+ make CC="${CC:-gcc}" \
+ CXX="${CXX:-g++}" \
+ CFLAGS="$CFLAGS -fPIC" \
+ CXXFLAGS="$CXXFLAGS" \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}
+
+md5sums="78724bf2a79878201c3bc81a1d8248ea sip-4.18.tar.gz"
+sha256sums="f1dc5c81c07a9ad97edcd4a0af964a41e420024ba7ca165afd2b351efd249cb6 sip-4.18.tar.gz"
+sha512sums="365fb51b8c833ebc923b87a961fac83976b653ebcec8fe7ad1543ee5a406471eb9309c8efbee6662c7b622f36771cd3ac31ede10208f23d2531a45af906d383d sip-4.18.tar.gz"