aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-smmap2
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 18:16:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 18:16:02 -0300
commit0d90cfd342ebce6999df24eb436e56c918cee106 (patch)
treecc3e09cd099cfe3371aaf9d63c8dc285977e3a3a /testing/py3-smmap2
parent3fead09c1153a52c21ec7e21ba7db516bddcfb4d (diff)
downloadaports-0d90cfd342ebce6999df24eb436e56c918cee106.tar.bz2
aports-0d90cfd342ebce6999df24eb436e56c918cee106.tar.xz
testing/py3-smmap2: new aport
https://github.com/gitpython-developers/smmap pure Python3 implementation of a sliding window memory map manager
Diffstat (limited to 'testing/py3-smmap2')
-rw-r--r--testing/py3-smmap2/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-smmap2/APKBUILD b/testing/py3-smmap2/APKBUILD
new file mode 100644
index 0000000000..8636b34010
--- /dev/null
+++ b/testing/py3-smmap2/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-smmap2
+pkgver=2.0.5
+pkgrel=0
+pkgdesc="pure Python3 implementation of a sliding window memory map manager"
+url="https://github.com/gitpython-developers/smmap"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-nose py3-nosexcover py3-coverage"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/smmap/archive/v$pkgver.tar.gz"
+builddir="$srcdir/smmap-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="78f1706fcf92cd39cb39190bc348534eb54bcc59ac8d8d0f9ca492fd83f999a6fc07bd86163614bcda5422ce887c3c1eceeafc79a6ff3031a37351c9be5518f7 py3-smmap2-2.0.5.tar.gz"