aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinx-theme-cloud
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 12:42:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 13:11:24 -0300
commitc1086fb4345ee517338255a90333a9b3c4e9c399 (patch)
tree3d171ec941412baaa509ce15a9b3fda5c33e885b /testing/py3-sphinx-theme-cloud
parentb130c78b65a9eb4b1297d80c08a6b7cccb53b42f (diff)
downloadaports-c1086fb4345ee517338255a90333a9b3c4e9c399.tar.bz2
aports-c1086fb4345ee517338255a90333a9b3c4e9c399.tar.xz
testing/py3-sphinx-theme-cloud: upgrade to 1.9.4
Diffstat (limited to 'testing/py3-sphinx-theme-cloud')
-rw-r--r--testing/py3-sphinx-theme-cloud/APKBUILD36
1 files changed, 11 insertions, 25 deletions
diff --git a/testing/py3-sphinx-theme-cloud/APKBUILD b/testing/py3-sphinx-theme-cloud/APKBUILD
index b6cfd79db4..1c1e14536d 100644
--- a/testing/py3-sphinx-theme-cloud/APKBUILD
+++ b/testing/py3-sphinx-theme-cloud/APKBUILD
@@ -1,41 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinx-theme-cloud
+pkgname=py3-sphinx-theme-cloud
_pkgname=cloud_sptheme
-pkgver=1.5
+pkgver=1.9.4
pkgrel=0
pkgdesc="The Cloud Sphinx theme"
url="https://bitbucket.org/ecollins/cloud_sptheme"
arch="noarch"
-license="BSD"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="BSD-3-Clause"
+depends="python3 py3-sphinx"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-sphinx-theme-cloud" # Backwards compatibility
+provides="py-sphinx-theme-cloud=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="d5a5f9d4996083ed661981f6d244eb93 cloud_sptheme-1.5.tar.gz"
-sha256sums="54967ff0a0d85fa592582c1ebd332d1aa709de2e4c5a3e360feea03803cb4293 cloud_sptheme-1.5.tar.gz"
-sha512sums="8c28c86f659447447eed64a90b872c04f94f1efcd6615f15ef8836c39674233fce34df8fe226f49f2142ce43c0a3daca2c1666c860e98ce5d66ac269c398d2c2 cloud_sptheme-1.5.tar.gz"
+sha512sums="83293e81c4430b457be25b9374b8e20d0c267acf6dae493766525cf5364f49996900cde0c64987ccf8ec65fde69d9aa1f47a56aa80d2325bd2346d356c503b7a cloud_sptheme-1.9.4.tar.gz"