aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinx-theme-epfl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 12:45:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 13:12:04 -0300
commitcf2770492e7af931e3dd1f2d3d836abf1d09a46e (patch)
tree449c55f321bea6038ddf9e5c2a9fca75ad07a09d /testing/py3-sphinx-theme-epfl
parentc1086fb4345ee517338255a90333a9b3c4e9c399 (diff)
downloadaports-cf2770492e7af931e3dd1f2d3d836abf1d09a46e.tar.bz2
aports-cf2770492e7af931e3dd1f2d3d836abf1d09a46e.tar.xz
testing/py3-sphinx-theme-epfl: rename from py-sphinx-theme-epfl
Diffstat (limited to 'testing/py3-sphinx-theme-epfl')
-rw-r--r--testing/py3-sphinx-theme-epfl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-sphinx-theme-epfl/APKBUILD b/testing/py3-sphinx-theme-epfl/APKBUILD
new file mode 100644
index 0000000000..1de3ac716b
--- /dev/null
+++ b/testing/py3-sphinx-theme-epfl/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-epfl
+_pkgname=epfl-sphinx-theme
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="The EPFL Sphinx theme"
+url="http://kis-doc.epfl.ch/sphinx/"
+arch="noarch"
+license="GPL-3.0"
+depends="python2 py-sphinx"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5d6d32f2757695b7671f71c6ca58cccd epfl-sphinx-theme-1.1.1.tar.gz"
+sha256sums="fa734959c14dd406f6a79ccfe85edb3f8bf203713d761e911bd00c2c46e11fcf epfl-sphinx-theme-1.1.1.tar.gz"
+sha512sums="af36469cbd33c5f8d1a4ebef201838a26dc52c04b1432b6cc49b46bfb74c585aad83da11cc9ebb675ad166573af41b00bed3e4ec770dcd60330599a732196ea0 epfl-sphinx-theme-1.1.1.tar.gz"