aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinx-theme-guzzle/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-29 01:36:01 +0300
committerprspkt <prspkt@protonmail.com>2019-05-29 01:53:39 +0300
commitd8ab4fdef8eb6d1085a7ec69e586e5609434c762 (patch)
treea146899357f58ca235c38757c92d852428cc18f1 /testing/py3-sphinx-theme-guzzle/APKBUILD
parent6db2bab9a186b28afde95e2b911fcccbf5f684c0 (diff)
downloadaports-d8ab4fdef8eb6d1085a7ec69e586e5609434c762.tar.bz2
aports-d8ab4fdef8eb6d1085a7ec69e586e5609434c762.tar.xz
testing/py-sphinx-theme-guzzle: upgrade to python3
Diffstat (limited to 'testing/py3-sphinx-theme-guzzle/APKBUILD')
-rw-r--r--testing/py3-sphinx-theme-guzzle/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-sphinx-theme-guzzle/APKBUILD b/testing/py3-sphinx-theme-guzzle/APKBUILD
new file mode 100644
index 0000000000..8ecb6278bd
--- /dev/null
+++ b/testing/py3-sphinx-theme-guzzle/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-sphinx-theme-guzzle
+_pkgname=guzzle_sphinx_theme
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="The Guzzle Sphinx theme"
+url="https://github.com/guzzle/guzzle_sphinx_theme"
+arch="noarch"
+license="MIT"
+depends="py3-sphinx"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2775b47a2ee27ab42de8247322676ab1bf2c4beb67e4c574b05ba08c22a71b61d5766d4dfa955f1f0dccfd57526b8251d8cec875bbf53d86e98402ddf3d20a81 guzzle_sphinx_theme-0.2.1.tar.gz"