aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-restbuilder
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 18:37:05 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 19:13:48 -0300
commit33601840a28fac6c1d08246fef4962c4b7831280 (patch)
treed529c9a6ef3d2bb26d680c48b7c257dbe957e57b /testing/py3-sphinxcontrib-restbuilder
parent98d91c6bf46db3afc84843a9db697b54e084dc0b (diff)
downloadaports-33601840a28fac6c1d08246fef4962c4b7831280.tar.bz2
aports-33601840a28fac6c1d08246fef4962c4b7831280.tar.xz
testing/py3-sphinxcontrib-restbuilder: rename from py-sphinxcontrib-restbuilder
Diffstat (limited to 'testing/py3-sphinxcontrib-restbuilder')
-rw-r--r--testing/py3-sphinxcontrib-restbuilder/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-sphinxcontrib-restbuilder/APKBUILD b/testing/py3-sphinxcontrib-restbuilder/APKBUILD
new file mode 100644
index 0000000000..21f869b520
--- /dev/null
+++ b/testing/py3-sphinxcontrib-restbuilder/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-restbuilder
+_pkgname=sphinxcontrib-restbuilder
+pkgver=0.1
+pkgrel=0
+pkgdesc="Sphinx restbuilder extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-restbuilder"
+arch="noarch"
+license="BSD"
+depends="python2 py-sphinx"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8ab68aba03133dde4b702380ff979a03 sphinxcontrib-restbuilder-0.1.tar.gz"
+sha256sums="8f2d7d73930fdedc3571adab32fbe843b4716829a291dbb27bab56b7c8d1e23d sphinxcontrib-restbuilder-0.1.tar.gz"
+sha512sums="ca8f20f5b637bf1e6ba19d17aea4aa942e8d661636f531ef97bbd4a9b11cc10700f865207510fd9fcefba4077e5cfb8acf00554addbcd1688459ba2e7f4fca1d sphinxcontrib-restbuilder-0.1.tar.gz"