aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-restbuilder
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 18:38:05 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 19:13:48 -0300
commit95a66754eef9ddd20e99dbbcf6910ce7480d591a (patch)
tree1fd3155dd9bf3bb2bb416bae703c5e5ed37c93f4 /testing/py3-sphinxcontrib-restbuilder
parent33601840a28fac6c1d08246fef4962c4b7831280 (diff)
downloadaports-95a66754eef9ddd20e99dbbcf6910ce7480d591a.tar.bz2
aports-95a66754eef9ddd20e99dbbcf6910ce7480d591a.tar.xz
testing/py3-sphinxcontrib-restbuilder: upgrade to 0.2
Diffstat (limited to 'testing/py3-sphinxcontrib-restbuilder')
-rw-r--r--testing/py3-sphinxcontrib-restbuilder/APKBUILD36
1 files changed, 11 insertions, 25 deletions
diff --git a/testing/py3-sphinxcontrib-restbuilder/APKBUILD b/testing/py3-sphinxcontrib-restbuilder/APKBUILD
index 21f869b520..bf61a96692 100644
--- a/testing/py3-sphinxcontrib-restbuilder/APKBUILD
+++ b/testing/py3-sphinxcontrib-restbuilder/APKBUILD
@@ -1,41 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-restbuilder
+pkgname=py3-sphinxcontrib-restbuilder
_pkgname=sphinxcontrib-restbuilder
-pkgver=0.1
+pkgver=0.2
pkgrel=0
pkgdesc="Sphinx restbuilder extension"
url="https://pypi.python.org/pypi/sphinxcontrib-restbuilder"
arch="noarch"
-license="BSD"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="BSD-2-Clause"
+depends="python3 py3-sphinx"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-sphinxcontrib-restbuilder" # Backwards compatibility
+provides="py-sphinxcontrib-restbuilder=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="8ab68aba03133dde4b702380ff979a03 sphinxcontrib-restbuilder-0.1.tar.gz"
-sha256sums="8f2d7d73930fdedc3571adab32fbe843b4716829a291dbb27bab56b7c8d1e23d sphinxcontrib-restbuilder-0.1.tar.gz"
-sha512sums="ca8f20f5b637bf1e6ba19d17aea4aa942e8d661636f531ef97bbd4a9b11cc10700f865207510fd9fcefba4077e5cfb8acf00554addbcd1688459ba2e7f4fca1d sphinxcontrib-restbuilder-0.1.tar.gz"
+sha512sums="502c051c7bb2295ce1e017a767d49259d19a0aa94c4d3a84a54081cd2fa104c2e8d39f4405cfcc19a4103ffb5fd8e63ff0dbc555d5d83d7098799d1e3d083810 sphinxcontrib-restbuilder-0.2.tar.gz"