aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-spelling
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 18:32:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 19:12:56 -0300
commit183e8d844e2cb15264d252b9d5e172f1feca2b53 (patch)
treebe781d9221d9371a269e7ee24bec7520f5ebf0f9 /testing/py3-sphinxcontrib-spelling
parent4b07730fd5c6d59572a9cd3992b65d339b88bd1e (diff)
downloadaports-183e8d844e2cb15264d252b9d5e172f1feca2b53.tar.bz2
aports-183e8d844e2cb15264d252b9d5e172f1feca2b53.tar.xz
testing/py3-sphinxcontrib-spelling: rename from py-sphinxcontrib-spelling
Diffstat (limited to 'testing/py3-sphinxcontrib-spelling')
-rw-r--r--testing/py3-sphinxcontrib-spelling/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/py3-sphinxcontrib-spelling/APKBUILD b/testing/py3-sphinxcontrib-spelling/APKBUILD
new file mode 100644
index 0000000000..1aa8908fc7
--- /dev/null
+++ b/testing/py3-sphinxcontrib-spelling/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-spelling
+_pkgname=sphinxcontrib-spelling
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="Sphinx spelling extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-spelling"
+arch="noarch"
+license="BSD-2-Clause"
+depends="py-sphinx py-enchant"
+depends_dev=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="1d850ac2388d859de0fd14a9414822dcaa8b9863a840569a1adb36c217ee37f44435b3283738ded6e876584a66f3826e7b1e440b214c9e1adb1ece46eb0b7eab sphinxcontrib-spelling-4.2.0.tar.gz"