aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-textstyle
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 18:27:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 19:12:07 -0300
commit1eebd9dc7f4eb49921286a7984f87aa150f6d16d (patch)
tree7a11a8c4fb5307ce9751078f15e944c525674fac /testing/py3-sphinxcontrib-textstyle
parentd6f2c16186310547f60a0d26081e48d3e9e3e464 (diff)
downloadaports-1eebd9dc7f4eb49921286a7984f87aa150f6d16d.tar.bz2
aports-1eebd9dc7f4eb49921286a7984f87aa150f6d16d.tar.xz
testing/py3-sphinxcontrib-textstyle: rename from py-sphinxcontrib-textstyle
Diffstat (limited to 'testing/py3-sphinxcontrib-textstyle')
-rw-r--r--testing/py3-sphinxcontrib-textstyle/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-sphinxcontrib-textstyle/APKBUILD b/testing/py3-sphinxcontrib-textstyle/APKBUILD
new file mode 100644
index 0000000000..9071f9a148
--- /dev/null
+++ b/testing/py3-sphinxcontrib-textstyle/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-textstyle
+_pkgname=sphinxcontrib-textstyle
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Sphinx textstyle extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-textstyle"
+arch="noarch"
+license="BSD"
+depends="python2 py-sphinx"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e24cdc85bc1353a04aa9e3cf25046b21 sphinxcontrib-textstyle-0.2.0.tar.gz"
+sha256sums="9369879ba5cfffadf1f0ee163247b7aff1e8e22d4cf56270c168e6ce4f0eab45 sphinxcontrib-textstyle-0.2.0.tar.gz"
+sha512sums="fe49ead9abfca36e15b3ed4e42ebacb734af6cfaf935a4f55781f53badf58275d4ae694c3d759961714a15cb3a7eb6cfe93cd41eca2b5556531610dad1edc4e0 sphinxcontrib-textstyle-0.2.0.tar.gz"