aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sshuttle
diff options
context:
space:
mode:
authorMichael Pirogov <vbnet.ru@gmail.com>2019-10-21 18:16:44 +0300
committerRasmus Thomsen <oss@cogitri.dev>2019-10-22 08:24:41 +0200
commit7396304d1cedc85a7a5b49200f6ce53f12bf8727 (patch)
treed70d0796ea3e0a210df096de898d7af37412de29 /testing/py3-sshuttle
parentbe3bd188b8d54b933c78b0f6578845d75fbc562f (diff)
downloadaports-7396304d1cedc85a7a5b49200f6ce53f12bf8727.tar.bz2
aports-7396304d1cedc85a7a5b49200f6ce53f12bf8727.tar.xz
testing/py3-sshuttle: new aport
Diffstat (limited to 'testing/py3-sshuttle')
-rw-r--r--testing/py3-sshuttle/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-sshuttle/APKBUILD b/testing/py3-sshuttle/APKBUILD
new file mode 100644
index 0000000000..7da034bee4
--- /dev/null
+++ b/testing/py3-sshuttle/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
+# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
+pkgname="py3-sshuttle"
+_pyname=sshuttle
+pkgver="0.78.5"
+pkgrel=0
+pkgdesc="Transparent proxy server that works as a poor man's VPN using ssh"
+url="https://github.com/sshuttle/sshuttle"
+arch="noarch"
+license="LGPL-2.1-or-later"
+depends="py3-setuptools"
+makedepends="py3-setuptools_scm"
+checkdepends="py3-pytest py3-pytest-mock py3-pytest-cov py3-pytest-runner py3-pytest-flake8"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+
+builddir=$srcdir/$_pyname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ chmod -R a+r "$pkgdir" # allow regular user
+}
+
+sha512sums="562acbf0e825ad41458c5b6065592a45b8bac92cd64b20619027fe4d0bec60a22c5191c7a7ed6b216d8cf5c9e027f58a6cdca69dd3a11ec6f6d348ef2f13bb38 sshuttle-0.78.5.tar.gz"