aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-telegram-bot
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 09:56:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 10:47:52 -0300
commit9c931ca93c7f80971e9c83e3020035a531883251 (patch)
treecb2198c8f17f0218b3b127bb9abf854e2d0488fa /testing/py3-telegram-bot
parent7dda81fb04ff5542d0924851c9a1eb0cf25eb99e (diff)
downloadaports-9c931ca93c7f80971e9c83e3020035a531883251.tar.bz2
aports-9c931ca93c7f80971e9c83e3020035a531883251.tar.xz
testing/py3-telegram-bot: upgrade to 12.0.0
Diffstat (limited to 'testing/py3-telegram-bot')
-rw-r--r--testing/py3-telegram-bot/APKBUILD45
1 files changed, 12 insertions, 33 deletions
diff --git a/testing/py3-telegram-bot/APKBUILD b/testing/py3-telegram-bot/APKBUILD
index d84e9f3ebe..fc1f4ac1e3 100644
--- a/testing/py3-telegram-bot/APKBUILD
+++ b/testing/py3-telegram-bot/APKBUILD
@@ -1,50 +1,29 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-telegram-bot
-_pkgname=${pkgname/py/python}
-pkgver=11.1.0
-pkgrel=1
+pkgname=py3-telegram-bot
+_pkgname=python-telegram-bot
+pkgver=12.0.0
+pkgrel=0
pkgdesc="A Python wrapper around the Telegram Bot API"
url="https://github.com/python-telegram-bot/python-telegram-bot"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="py-certifi"
+depends="py3-future py3-certifi py3-tornado py3-cryptography"
#checkdepends="pytest py-cffi py-cryptography py-future py-pathlib2"
options="!check" # few requirements-dev.txt packages missing in alpine
-makedepends="python2-dev python3-dev py2-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.zip::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.zip"
+makedepends="py3-setuptools"
+source="https://github.com/python-telegram-bot/python-telegram-bot/releases/download/v$pkgver/python-telegram-bot-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-telegram-bot" # Backwards compatibility
+provides="py-telegram-bot=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="py2-futures ${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="2f9f13dfd784a48e05537a3038057ca4f03d075132af2bd3cc8a67e4f6bd1a8c361afd4f508529a5031938b005a2b1442085c84b353e58d39a99292c6d037730 py-telegram-bot-11.1.0.zip"
+sha512sums="847f11b642fde3d37101e032c647ef2adf4a8b0e6cee7267b32ac62e0f82db8dc50c6086e9472c81ed713a4804e908adabde2c612a94120a60326681512c1745 python-telegram-bot-12.0.0.tar.gz"