aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-testtools
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 08:42:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 08:42:11 -0300
commit16ae66e886224e5847190f75dfe60c1cf7daa3f1 (patch)
tree2d1686af49ef611b0d6334eb19b60f70233d6d71 /testing/py3-testtools
parentb8443f3b3bc3b8bea5ff9bf12d89398cf414a11a (diff)
downloadaports-16ae66e886224e5847190f75dfe60c1cf7daa3f1.tar.bz2
aports-16ae66e886224e5847190f75dfe60c1cf7daa3f1.tar.xz
testing/py3-testtools: drop py2
Diffstat (limited to 'testing/py3-testtools')
-rw-r--r--testing/py3-testtools/APKBUILD38
1 files changed, 8 insertions, 30 deletions
diff --git a/testing/py3-testtools/APKBUILD b/testing/py3-testtools/APKBUILD
index 96de9de3b3..2dbbb62ccf 100644
--- a/testing/py3-testtools/APKBUILD
+++ b/testing/py3-testtools/APKBUILD
@@ -1,51 +1,29 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-testtools
-_pkgname="testtools"
+pkgname=py3-testtools
+_pkgname=testtools
pkgver=2.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="Extensions to the Python standard library unit testing framework"
url="https://pypi.python.org/pypi/testtools"
arch="noarch"
license="MIT"
-depends="python py-pbr py-setuptools py-fixtures py-extras py-six py-mimeparse"
-makedepends="py3-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3 py3-pbr py3-setuptools py3-fixtures py3-extras py3-six py3-mimeparse"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-testtools" # Backwards compatibility
+provides="py-testtools=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py check
python3 setup.py check
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-} py2-traceback2 py2-unittest2" ## remove if there are no common Python dependencies
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python" ## remove if arch isn't noarch
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="558fe6a1bdce7215f9f6f178f469a2b76948dc7ff0ce27400482a16683474edb81d9bf90ae48b6fcb8df9eb70759341b694aa162ed3d9d4abd372981cdcd8a64 testtools-2.3.0.tar.gz"