aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-thinc
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-05-22 15:48:25 -0500
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 22:14:31 -0300
commitb1a91477c2179482796be71c0c2ed6a3a410bd39 (patch)
tree6bc8131ba3f032f8691ed21eb9a57cc242c9d3ae /testing/py3-thinc
parentb1547c23df44f4839f97a85f44cd1074ddddc3a5 (diff)
downloadaports-b1a91477c2179482796be71c0c2ed6a3a410bd39.tar.bz2
aports-b1a91477c2179482796be71c0c2ed6a3a410bd39.tar.xz
testing/py3-thinc: new aport
https://github.com/explosion/thinc spaCy's Machine Learning library for NLP in Python
Diffstat (limited to 'testing/py3-thinc')
-rw-r--r--testing/py3-thinc/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-thinc/APKBUILD b/testing/py3-thinc/APKBUILD
new file mode 100644
index 0000000000..8a545a01a6
--- /dev/null
+++ b/testing/py3-thinc/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=py3-thinc
+pkgver=7.1.1
+pkgrel=0
+pkgdesc="Practical Machine Learning for NLP"
+url="https://github.com/explosion/thinc"
+arch="x86_64"
+license="MIT"
+depends="python3 py3-cymem py3-preshed py3-murmurhash py3-blis py3-plac py3-srsly py3-wasabi"
+makedepends="python3-dev py3-setuptools cython"
+checkdepends="py3-pytest py3-numpy py3-mock py3-tqdm py3-hypothesis"
+subpackages="$pkgname-doc"
+source="thinc-$pkgver.tar.gz::https://github.com/explosion/thinc/archive/v$pkgver.tar.gz"
+builddir="$srcdir/thinc-$pkgver"
+
+build() {
+ python3 setup.py build_ext --inplace
+}
+
+check() {
+ pytest-3 thinc
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+sha512sums="48b78cd97e281d383afadff21f59221dd462a92536f151a292a94c49713660c2bcc252d4ad9874e85ecb9d675aeafaa1b250eee8b0f588713bdd1a7f3396f590 thinc-7.1.1.tar.gz"