aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-twine
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-11 17:23:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-11 17:54:04 -0300
commitbf1b38c7fc1a591f32210e4bd37b6bf82568c856 (patch)
tree153e6ea41f926f7fa3302c611627c68265ef286b /testing/py3-twine
parentddda16d258f730591ed59e0fbeddfb98548c9b73 (diff)
downloadaports-bf1b38c7fc1a591f32210e4bd37b6bf82568c856.tar.bz2
aports-bf1b38c7fc1a591f32210e4bd37b6bf82568c856.tar.xz
testing/py3-twine: new aport
https://twine.readthedocs.io/en/latest/ Collection of utilities for publishing packages on PyPI
Diffstat (limited to 'testing/py3-twine')
-rw-r--r--testing/py3-twine/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py3-twine/APKBUILD b/testing/py3-twine/APKBUILD
new file mode 100644
index 0000000000..ca5351b893
--- /dev/null
+++ b/testing/py3-twine/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-twine
+_pkgname=twine
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Collection of utilities for publishing packages on PyPI"
+options="!check" # Requires unpackaged 'pretend'
+url="https://twine.readthedocs.io/en/latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="
+ python3
+ py3-pkginfo
+ py3-readme_renderer
+ py3-requests
+ py3-requests-toolbelt
+ py3-setuptools
+ py3-tqdm
+ "
+checkdepends="py3-pytest"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" py.test-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c7db20800191accf3324b959a9ddeef3c35141cde77de9788b239fe764006dd20b8236c2cbd23192af2ac592567e6c917896e1402dfa96b964699aefb636968d twine-2.0.0.tar.gz"