aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ufonormalizer
diff options
context:
space:
mode:
authorSascha Brawer <sascha@brawer.ch>2020-03-09 07:40:10 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 13:37:41 -0300
commit32cfe87414bdb9474d95aee417a2f1132cb0f2cb (patch)
tree579315b462dd78053b6bd1327b8692c9351974f1 /testing/py3-ufonormalizer
parent4cf0d259f3aee281629f5ce056fecd58cb53239a (diff)
downloadaports-32cfe87414bdb9474d95aee417a2f1132cb0f2cb.tar.bz2
aports-32cfe87414bdb9474d95aee417a2f1132cb0f2cb.tar.xz
testing/py3-ufonormalizer: new aport
Normalize the XML and other data inside UFO font design sources https://github.com/unified-font-object/ufoNormalizer
Diffstat (limited to 'testing/py3-ufonormalizer')
-rw-r--r--testing/py3-ufonormalizer/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-ufonormalizer/APKBUILD b/testing/py3-ufonormalizer/APKBUILD
new file mode 100644
index 0000000000..97820a00ec
--- /dev/null
+++ b/testing/py3-ufonormalizer/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Sascha Brawer <sascha@brawer.ch>
+# Maintainer: Sascha Brawer <sascha@brawer.ch>
+pkgname=py3-ufonormalizer
+_pyname=ufonormalizer
+pkgver=0.3.6
+pkgrel=0
+pkgdesc="Normalize the XML and other data inside UFO font design sources"
+url="https://github.com/unified-font-object/ufoNormalizer"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/u/$_pyname/$_pyname-$pkgver.zip"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ # Make files world-readable so others than root can run the installed script.
+ chmod -R a+r "$pkgdir"/usr/lib/python3*/site-packages
+}
+
+
+sha512sums="9cb3dff2ee4176746025cec58256c45cdd1f834e5647e7d07d613bb979993f9c01d16e613b0b1649e637a7cd6bfc57956a99f630c73833c625ce4a55d3c0a661 ufonormalizer-0.3.6.zip"