aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-unicorn-hat
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 09:07:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 22:19:42 -0300
commit6c4a8bfcfce82d2689865e7f33fb73e2da1233a2 (patch)
tree83e97deb4785e9dd3d70647ba271b3ad28dee5dd /testing/py3-unicorn-hat
parentcb892cb626e7ee35b1685e1572c6d6754d2610b7 (diff)
downloadaports-6c4a8bfcfce82d2689865e7f33fb73e2da1233a2.tar.bz2
aports-6c4a8bfcfce82d2689865e7f33fb73e2da1233a2.tar.xz
testing/py3-unicorn-hat: rename from py-unicorn-hat
Diffstat (limited to 'testing/py3-unicorn-hat')
-rw-r--r--testing/py3-unicorn-hat/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py3-unicorn-hat/APKBUILD b/testing/py3-unicorn-hat/APKBUILD
new file mode 100644
index 0000000000..ec85874c54
--- /dev/null
+++ b/testing/py3-unicorn-hat/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=py-unicorn-hat
+_pkgname=unicorn-hat-unicornhat
+pkgver=2.1.2
+pkgrel=0
+pkgdesc="Python wrapper for driving ws2812 pixels from the Raspberry Pi"
+url="http://shop.pimoroni.com/products/unicorn-hat"
+arch="armhf armv7 aarch64"
+license="GPL-2.0"
+depends="python2"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pimoroni/unicorn-hat/archive/unicornhat-${pkgver}.tar.gz"
+
+builddir=${srcdir}/${_pkgname}-${pkgver}
+
+prepare() {
+ local i
+ cd "$builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$builddir/python/UnicornHat"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir/python/UnicornHat"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -D -m0644 $builddir/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
+md5sums="63a61940a4ee469d0235454629ea60d3 py-unicorn-hat-2.1.2.tar.gz"
+sha256sums="b19430964934412b6b76dfa7b6ed7924610bda0d10e2cba47a2c580baa10da8c py-unicorn-hat-2.1.2.tar.gz"
+sha512sums="dee24ec570b8624792899fbf98fafea6565b939581ecce0adcf78c389cc0f2ec274466be31bf3e09c861a30a074f491f1366b0ac4a55529c259bfb3869d96bef py-unicorn-hat-2.1.2.tar.gz"