aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-unicorn-hat
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 09:10:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 22:19:42 -0300
commit2df21fe4791d7cdf9d723b27dba36c90f53680fd (patch)
tree2b17214b4f29076ee36bc16137ec56ca745266b4 /testing/py3-unicorn-hat
parent6c4a8bfcfce82d2689865e7f33fb73e2da1233a2 (diff)
downloadaports-2df21fe4791d7cdf9d723b27dba36c90f53680fd.tar.bz2
aports-2df21fe4791d7cdf9d723b27dba36c90f53680fd.tar.xz
testing/py3-unicorn-hat: drop py2
Diffstat (limited to 'testing/py3-unicorn-hat')
-rw-r--r--testing/py3-unicorn-hat/APKBUILD39
1 files changed, 12 insertions, 27 deletions
diff --git a/testing/py3-unicorn-hat/APKBUILD b/testing/py3-unicorn-hat/APKBUILD
index ec85874c54..e22db71141 100644
--- a/testing/py3-unicorn-hat/APKBUILD
+++ b/testing/py3-unicorn-hat/APKBUILD
@@ -1,42 +1,27 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
-pkgname=py-unicorn-hat
+pkgname=py3-unicorn-hat
_pkgname=unicorn-hat-unicornhat
pkgver=2.1.2
-pkgrel=0
+pkgrel=1
pkgdesc="Python wrapper for driving ws2812 pixels from the Raspberry Pi"
url="http://shop.pimoroni.com/products/unicorn-hat"
arch="armhf armv7 aarch64"
-license="GPL-2.0"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/pimoroni/unicorn-hat/archive/unicornhat-${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pimoroni/unicorn-hat/archive/unicornhat-$pkgver.tar.gz"
+builddir=$srcdir/$_pkgname-$pkgver/python/UnicornHat
-builddir=${srcdir}/${_pkgname}-${pkgver}
-
-prepare() {
- local i
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-unicorn-hat" # Backwards compatibility
+provides="py-unicorn-hat=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir/python/UnicornHat"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir/python/UnicornHat"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
- install -D -m0644 $builddir/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="63a61940a4ee469d0235454629ea60d3 py-unicorn-hat-2.1.2.tar.gz"
-sha256sums="b19430964934412b6b76dfa7b6ed7924610bda0d10e2cba47a2c580baa10da8c py-unicorn-hat-2.1.2.tar.gz"
-sha512sums="dee24ec570b8624792899fbf98fafea6565b939581ecce0adcf78c389cc0f2ec274466be31bf3e09c861a30a074f491f1366b0ac4a55529c259bfb3869d96bef py-unicorn-hat-2.1.2.tar.gz"
+sha512sums="dee24ec570b8624792899fbf98fafea6565b939581ecce0adcf78c389cc0f2ec274466be31bf3e09c861a30a074f491f1366b0ac4a55529c259bfb3869d96bef py3-unicorn-hat-2.1.2.tar.gz"