aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-unoconv/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-14 11:43:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-14 11:48:36 +0000
commit36ccfc91839920ddebac20317be9d72c240273b2 (patch)
treebcf5c9a1bf75fe7d39ebd525bd42aaff478c226b /testing/py3-unoconv/APKBUILD
parent3d60f5daf2c89dd871b57ac292ec69aa955ef885 (diff)
downloadaports-36ccfc91839920ddebac20317be9d72c240273b2.tar.bz2
aports-36ccfc91839920ddebac20317be9d72c240273b2.tar.xz
testing/py3-unoconv: cleanup
Diffstat (limited to 'testing/py3-unoconv/APKBUILD')
-rw-r--r--testing/py3-unoconv/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-unoconv/APKBUILD b/testing/py3-unoconv/APKBUILD
new file mode 100644
index 0000000000..60733aefe1
--- /dev/null
+++ b/testing/py3-unoconv/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: TBK <tbk@jjtc.eu>
+pkgname=py3-unoconv
+pkgver=0.7
+pkgrel=0
+pkgdesc="Tool to convert between any document format supported by LibreOffice"
+url="http://dag.wieers.com/home-made/unoconv/"
+arch="noarch"
+license="GPL2"
+depends="libreoffice python3"
+makedepends="python3-dev py-setuptools"
+subpackages=""
+source="unoconv-${pkgver}.tar.gz::https://github.com/dagwieers/unoconv/archive/$pkgver.tar.gz
+ setup.py"
+builddir="$srcdir"/unoconv-$pkgver
+
+prepare() {
+ cp "$srcdir"/setup.py "$builddir"/
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3b0837e11f22733e0fbef93dc6aeabd0e2d3d59b6c35a6f7b29b86506a5842bcbffb3e889864d6e14c1e53dd306354690a699257fe60f36ce1d4455ab52b5df7 unoconv-0.7.tar.gz
+b4fa76011fb96ba9521bb09d1a5c43dbd457c50bb2c6d66a5bc65928cde1e1d8174e43ad86f8f53755f222127cc5b0084b4564c248ce1fca56f9acfb4c03d86d setup.py"