aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-unoconv/setup.py
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-14 11:43:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-14 11:48:36 +0000
commit36ccfc91839920ddebac20317be9d72c240273b2 (patch)
treebcf5c9a1bf75fe7d39ebd525bd42aaff478c226b /testing/py3-unoconv/setup.py
parent3d60f5daf2c89dd871b57ac292ec69aa955ef885 (diff)
downloadaports-36ccfc91839920ddebac20317be9d72c240273b2.tar.bz2
aports-36ccfc91839920ddebac20317be9d72c240273b2.tar.xz
testing/py3-unoconv: cleanup
Diffstat (limited to 'testing/py3-unoconv/setup.py')
-rw-r--r--testing/py3-unoconv/setup.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py3-unoconv/setup.py b/testing/py3-unoconv/setup.py
new file mode 100644
index 0000000000..9f1b45fc91
--- /dev/null
+++ b/testing/py3-unoconv/setup.py
@@ -0,0 +1,42 @@
+"""
+Universal Office Converter - Convert between any document format supported by LibreOffice/OpenOffice.
+
+See:
+https://github.com/dagwieers/unoconv
+"""
+
+# Always prefer setuptools over distutils
+from setuptools import setup, find_packages
+# To use a consistent encoding
+from codecs import open
+from os import path
+
+here = path.abspath(path.dirname(__file__))
+# Get the long description from the README file
+with open(path.join(here, 'README.adoc'), encoding='utf-8') as f:
+ long_description = f.read()
+
+setup(name = "unoconv",
+ version = "0.7",
+ author = "Dag Wieers",
+ author_email = "dag.wieers@gmail.com",
+ url = "https://github.com/dagwieers/unoconv",
+ description = "Universal Office Converter - Convert between any document format supported by LibreOffice/OpenOffice.",
+ scripts = ["unoconv"],
+ # See https://pypi.python.org/pypi?%3Aaction=list_classifiers
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'Intended Audience :: Education',
+ 'License :: OSI Approved :: GNU General Public License v2 (GPLv2)',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Documentation',
+ 'Topic :: Office/Business :: Office Suites',
+ 'Topic :: Utilities',
+
+ ]
+)