aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-update-checker/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-02 03:15:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 07:04:03 -0300
commitaaa5e4069a788f976e6e5efc023d575671023e5d (patch)
treea3f2c159b917ab26fc2529a698dacffebb4a0c9f /testing/py3-update-checker/APKBUILD
parent9a9066dc0737a0d63ee80d5f1e0369c9f69e3484 (diff)
downloadaports-aaa5e4069a788f976e6e5efc023d575671023e5d.tar.bz2
aports-aaa5e4069a788f976e6e5efc023d575671023e5d.tar.xz
testing/py3-update-checker: rebuild as python3 only
Diffstat (limited to 'testing/py3-update-checker/APKBUILD')
-rw-r--r--testing/py3-update-checker/APKBUILD41
1 files changed, 14 insertions, 27 deletions
diff --git a/testing/py3-update-checker/APKBUILD b/testing/py3-update-checker/APKBUILD
index f245d54fb3..e52264ede0 100644
--- a/testing/py3-update-checker/APKBUILD
+++ b/testing/py3-update-checker/APKBUILD
@@ -1,45 +1,32 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-update-checker
+pkgname=py3-update-checker
_pkgname=update_checker
pkgver=0.16
-pkgrel=1
+pkgrel=2
pkgdesc="A python module that will check for package updates"
+options="!check" # 4 tests fail
url="https://github.com/bboe/update_checker"
arch="noarch"
-license="BSD"
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+license="BSD-2-Clause"
+depends="python3 py3-requests"
+makedepends="py3-setuptools"
source="$_pkgname-$pkgver.tar.gz::https://github.com/bboe/update_checker/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-build() {
- cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
+replaces="py-update-checker" # Backwards compatibility
+provides="py-update-checker=$pkgver-r$pkgrel" # Backwards compatibility
-_py2() {
- replaces="$pkgname"
- _py python2
+build() {
+ python3 setup.py build
}
-_py3() {
- _py python3
+check() {
+ python3 setup.py test
}
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="31533162b27e2c920c5565007feb6c765d7026a76b3ff95df374317f7beae79ed705771c91d5099fd6104f6c155f957d5e624583a4a5c7c0abccf6a7bacd9aee update_checker-0.16.tar.gz"