aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-urlobject
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-02 03:46:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 05:15:56 -0300
commit6b7d4616097280108dc45136aab125d3b5a0c017 (patch)
tree7b638a53ede4d30ce70b0a12ed62466b88562c89 /testing/py3-urlobject
parent99dc7d5ac4e0908447784e4003357810d387bc02 (diff)
downloadaports-6b7d4616097280108dc45136aab125d3b5a0c017.tar.bz2
aports-6b7d4616097280108dc45136aab125d3b5a0c017.tar.xz
testing/py3-urlobject: rename from py-urlobject
Diffstat (limited to 'testing/py3-urlobject')
-rw-r--r--testing/py3-urlobject/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/py3-urlobject/APKBUILD b/testing/py3-urlobject/APKBUILD
new file mode 100644
index 0000000000..552ae661ab
--- /dev/null
+++ b/testing/py3-urlobject/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-urlobject
+_pkgname=URLObject
+pkgver=2.4.3
+pkgrel=1
+pkgdesc="A Python utility class for manipulating URLs"
+url="https://github.com/dperezrada/html2data"
+arch="noarch"
+license="Unlicense"
+makedepends="py-setuptools py3-setuptools"
+checkdepends="py-nose py3-nose"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+# Tests are not included at the moment
+check() {
+ PYTHONPATH="${PWD}/build/lib" nosetests-2.7 -w test
+ PYTHONPATH="${PWD}/build/lib" nosetests -w test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="a557731f4da8a2aaf8f7e3f7219b48cf66cf6a5706a0ba6978e9eeb310d8246baec6a6c9d798e31ac1b3874fd0d93bb88ea359a87390f7b935ba5472994e1bbe URLObject-2.4.3.tar.gz"