aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-usb
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 22:45:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 23:02:26 -0300
commit16c495dee9026ae6b962ad0f15ea1c36621eacd8 (patch)
tree6b81c05a9688174f931694de0b845e050394a64e /testing/py3-usb
parentcafb98cd911a3190f83f1950349d201908131dd2 (diff)
downloadaports-16c495dee9026ae6b962ad0f15ea1c36621eacd8.tar.bz2
aports-16c495dee9026ae6b962ad0f15ea1c36621eacd8.tar.xz
testing/py3-usb: rename from py-usb
Diffstat (limited to 'testing/py3-usb')
-rw-r--r--testing/py3-usb/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py3-usb/APKBUILD b/testing/py3-usb/APKBUILD
new file mode 100644
index 0000000000..77231c6b2f
--- /dev/null
+++ b/testing/py3-usb/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py-usb
+_pkgname=pyusb
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="PyUSB offers easy USB devices communication in Python"
+url="https://pypi.python.org/pypi/pyusb"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+sha512sums="218d118c8572ed548d2317725a9717c0a442eb67c05148ccd90505a407bd8821a1519f511abc14f96b8e09d914f5a35f57cfabd57c47cb9b3fcd8b61947375a2 pyusb-1.0.2.tar.gz"