aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-utc
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-25 20:32:55 +0200
committerprspkt <prspkt@protonmail.com>2019-03-25 20:47:57 +0200
commit567abdb8c0b5440b9a8d75fb53677ae9ed8f0c06 (patch)
tree5d76a2c55b5553049b1adbf0f613995b4a033490 /testing/py3-utc
parent5cb175e7c7cab10f3a3c047730221624d2030122 (diff)
downloadaports-567abdb8c0b5440b9a8d75fb53677ae9ed8f0c06.tar.bz2
aports-567abdb8c0b5440b9a8d75fb53677ae9ed8f0c06.tar.xz
testing/py-utc: upgrade to python3
Diffstat (limited to 'testing/py3-utc')
-rw-r--r--testing/py3-utc/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-utc/APKBUILD b/testing/py3-utc/APKBUILD
new file mode 100644
index 0000000000..343e4b9fbe
--- /dev/null
+++ b/testing/py3-utc/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-utc
+_pkgname=utc
+pkgver=0.0.3
+pkgrel=0
+pkgdesc="A tiny library for working with UTC time"
+url="https://bitbucket.org/btubbs/utc"
+arch="noarch"
+license="MIT"
+provides="py-utc" # for backwards compatibility
+replaces="py-utc=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="efaa3ad007d658b05588eb995f23a5873d3e04f769cae00ca44feb65f29f54340dbe0bf73237c9300fb2cf61274318c77f446301a0fc4ebfeb4a67beeaf9a24b utc-0.0.3.tar.gz"