aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-wasabi
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-05-22 12:41:08 -0500
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 05:52:19 -0300
commita1b2b18002c4baf7bbd9a3a94f1be0e22f002a15 (patch)
treee4b3bbe1bc2fff0281e9097a8fcc9f2312392801 /testing/py3-wasabi
parentd9dda14dfeec564d19c47cfa97db3b7245ef3f08 (diff)
downloadaports-a1b2b18002c4baf7bbd9a3a94f1be0e22f002a15.tar.bz2
aports-a1b2b18002c4baf7bbd9a3a94f1be0e22f002a15.tar.xz
testing/py3-wasabi: new aport
https://github.com/ines/wasabi A lightweight console printing and formatting toolkit
Diffstat (limited to 'testing/py3-wasabi')
-rw-r--r--testing/py3-wasabi/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-wasabi/APKBUILD b/testing/py3-wasabi/APKBUILD
new file mode 100644
index 0000000000..b6de0191db
--- /dev/null
+++ b/testing/py3-wasabi/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=py3-wasabi
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="A lightweight console printing and formatting toolkit"
+url="https://github.com/ines/wasabi"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc"
+source="wasabi-$pkgver.tar.gz::https://github.com/ines/wasabi/archive/v$pkgver.tar.gz"
+builddir="$srcdir/wasabi-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest-3 wasabi
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+sha512sums="043e6c76cf9664da61ddfbe5665e856fc528d04a1eeb16f9a57d01371717a0fe878a5ad5f82523d63db97d8a8acd31da63c1b567b62eac3af7fc1f42c70bddb8 wasabi-0.3.0.tar.gz"