aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-webob
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 08:44:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 09:02:55 -0300
commit6bdc9c18cadc1b3fb69670a5202c209f070fcae3 (patch)
tree81f837d566cfd6e92f638a31c96928dfb897fc6f /testing/py3-webob
parent066aa4ac3f6bb3e28f2dbf71ec710319fbba5d19 (diff)
downloadaports-6bdc9c18cadc1b3fb69670a5202c209f070fcae3.tar.bz2
aports-6bdc9c18cadc1b3fb69670a5202c209f070fcae3.tar.xz
testing/py3-webob: drop py2
Diffstat (limited to 'testing/py3-webob')
-rw-r--r--testing/py3-webob/APKBUILD38
1 files changed, 8 insertions, 30 deletions
diff --git a/testing/py3-webob/APKBUILD b/testing/py3-webob/APKBUILD
index b3a7be7390..d321ffdfb2 100644
--- a/testing/py3-webob/APKBUILD
+++ b/testing/py3-webob/APKBUILD
@@ -1,25 +1,22 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-webob
+pkgname=py3-webob
_pkgname=WebOb
pkgver=1.8.5
-pkgrel=0
+pkgrel=1
pkgdesc="A Python WSGI request and response objects"
url="https://webob.org/"
arch="noarch"
license="MIT"
-makedepends="py-setuptools py3-setuptools"
-checkdepends="
- py3-pytest py3-pytest-runner
- py-wcwidth py3-wcwidth
- " # Remove these once pytest get it as depends
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-runner"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-webob" # Backwards compatibility
+provides="py-webob=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
@@ -28,26 +25,7 @@ check() {
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="cc0b956a7c3b8ae58d6002baf5c6de4e442201280468f8fc8b5fbd2c7f7cb7a8f46447f97b98a32a9959c8d1aa7a2a8a7b9d624cb27ca79b2ad1ce94f891801b WebOb-1.8.5.tar.gz"