aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-webtest
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-29 21:30:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-12 17:27:31 -0300
commit4ff310b0e6e16852463744a08156d834505d572c (patch)
tree6865765d66590083b6c3b8f5c726026412980478 /testing/py3-webtest
parent048e2c11854620de9344011ee788687aa324ef54 (diff)
downloadaports-4ff310b0e6e16852463744a08156d834505d572c.tar.bz2
aports-4ff310b0e6e16852463744a08156d834505d572c.tar.xz
testing/py3-webtest: rename from py-webtest
Diffstat (limited to 'testing/py3-webtest')
-rw-r--r--testing/py3-webtest/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py3-webtest/APKBUILD b/testing/py3-webtest/APKBUILD
new file mode 100644
index 0000000000..6d9d7b1b7a
--- /dev/null
+++ b/testing/py3-webtest/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-webtest
+_pkgname=WebTest
+pkgver=2.0.9
+pkgrel=0
+pkgdesc="A Helper to test WSGI applications"
+url="http://webtest.pythonpaste.org/"
+arch="noarch"
+license="MIT"
+depends="python2"
+depends_dev=""
+makedepends="python2-dev py-setuptools py-waitress py-six py-beautifulsoup4
+ py-webob"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="bf0a04fcf8b2cdcaa13b04324cefb53d WebTest-2.0.9.zip"
+sha256sums="749f527b39893b1757abd0e6814bde811eb25a6cf42538585c971afdb9030dad WebTest-2.0.9.zip"
+sha512sums="004848c0474a06f81849b1983d9c50ba9e142b7bfb1ce64924074b197f26cb15ac272fe5917a9c7c04b38ff2b39d191cc8d310dd2f321be878deeff710294d7a WebTest-2.0.9.zip"