aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-whatever
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-17 06:25:58 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-17 06:34:26 +0100
commit1ee750b7dec77fb8c1ab8c4adcce1f1601d7c5ee (patch)
tree8262588acc64ecc86315156f5afc4b66d9d094ac /testing/py3-whatever
parent04e9993b3ec3957280e6fd7f8b7af839bbfac83b (diff)
downloadaports-1ee750b7dec77fb8c1ab8c4adcce1f1601d7c5ee.tar.bz2
aports-1ee750b7dec77fb8c1ab8c4adcce1f1601d7c5ee.tar.xz
testing/py3-whatever: upgrade to 0.6
Diffstat (limited to 'testing/py3-whatever')
-rw-r--r--testing/py3-whatever/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/testing/py3-whatever/APKBUILD b/testing/py3-whatever/APKBUILD
index d0c55d0f2b..cafb162065 100644
--- a/testing/py3-whatever/APKBUILD
+++ b/testing/py3-whatever/APKBUILD
@@ -2,31 +2,28 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-whatever
_pkgname=whatever
-pkgver=0.5
-pkgrel=1
+pkgver=0.6
+pkgrel=0
pkgdesc="Easy anonymous functions by partial application of operators"
url="https://github.com/Suor/whatever"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
checkdepends="py3-pytest"
-makedepends="python3-dev"
+makedepends="py3-setuptools"
source="https://github.com/Suor/whatever/archive/$pkgver/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 -m pytest .
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="eb3f0b9bc63197c1bfdd135a46a597e2f5d6131900910f266c984c1afd901d6cbc8c8ee62397e9af8393bf34beff068dc0007e8b016e70f275e019420f18f6e1 whatever-0.5.tar.gz"
+sha512sums="f982100f0d6a8bf4c30e452a083c75f4cb2bca07e57e40ba4fd66baca752f039aea9519ffb97b3d43708df0ff5e981d0c4d03773f225106aa2f43e7770ee1975 whatever-0.6.tar.gz"