aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-wrapt/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-29 23:18:16 +0300
committerprspkt <prspkt@protonmail.com>2019-05-30 01:12:50 +0300
commita6c0b1f90ec0f9a797f1fc0a1edd08bb63166442 (patch)
tree5027387918b9b3108c20de8c0c85be64bf6c8f42 /testing/py3-wrapt/APKBUILD
parentd8b304012dd88cdd7c7a7e37db98e18f22a9b37e (diff)
downloadaports-a6c0b1f90ec0f9a797f1fc0a1edd08bb63166442.tar.bz2
aports-a6c0b1f90ec0f9a797f1fc0a1edd08bb63166442.tar.xz
testing/py3-wrapt: new aport
Diffstat (limited to 'testing/py3-wrapt/APKBUILD')
-rw-r--r--testing/py3-wrapt/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-wrapt/APKBUILD b/testing/py3-wrapt/APKBUILD
new file mode 100644
index 0000000000..cd533b5ff0
--- /dev/null
+++ b/testing/py3-wrapt/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-wrapt
+_pkgname=wrapt
+pkgver=1.11.1
+pkgrel=0
+pkgdesc="Module for decorators, wrappers and monkey patching"
+url="https://github.com/GrahamDumpleton/wrapt"
+arch="all"
+license="BSD-2-Clause"
+depends="python3"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="82cf9a2113dd73d692033ed5b8d1c6475873c8676cb33bd42384a7a27bff1451809ff490f755d31e1753fc1f7eb8288474873753eed1c0c6a61cda6f7cff17b7 wrapt-1.11.1.tar.gz"