aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-wtf-peewee
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-02 21:55:19 +0300
committerprspkt <prspkt@protonmail.com>2019-06-02 22:44:16 +0300
commite44ab41da927bc2344097875eb13a78ba9e61365 (patch)
treec2f025bee7e590e9ab5ac96cad83b79c7d631937 /testing/py3-wtf-peewee
parentff6653cf62c005d4dbf732b3c86c1ef7d4779d00 (diff)
downloadaports-e44ab41da927bc2344097875eb13a78ba9e61365.tar.bz2
aports-e44ab41da927bc2344097875eb13a78ba9e61365.tar.xz
testing/py3-wtf-peewee: modernize
Diffstat (limited to 'testing/py3-wtf-peewee')
-rw-r--r--testing/py3-wtf-peewee/APKBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/testing/py3-wtf-peewee/APKBUILD b/testing/py3-wtf-peewee/APKBUILD
index 0a4a27df47..c36c6e4754 100644
--- a/testing/py3-wtf-peewee/APKBUILD
+++ b/testing/py3-wtf-peewee/APKBUILD
@@ -8,27 +8,21 @@ pkgdesc="WTForms integration for peewee"
url="https://github.com/coleifer/wtf-peewee"
arch="noarch"
license="MIT"
-depends="python3 py-peewee"
-depends_dev=""
-makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
+depends="py3-peewee"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}