aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-xlib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 04:55:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 05:55:34 -0300
commit50ac7dd12e6764164516df554c46396e4613f2de (patch)
tree61737b38554a0b977a267f3abf1f1ba5f1f4f873 /testing/py3-xlib
parent1f823a34995eb5f29f70396c984af64762121d41 (diff)
downloadaports-50ac7dd12e6764164516df554c46396e4613f2de.tar.bz2
aports-50ac7dd12e6764164516df554c46396e4613f2de.tar.xz
testing/py3-xlib: rename from py-xlib
Diffstat (limited to 'testing/py3-xlib')
-rw-r--r--testing/py3-xlib/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/testing/py3-xlib/APKBUILD b/testing/py3-xlib/APKBUILD
new file mode 100644
index 0000000000..5c37261013
--- /dev/null
+++ b/testing/py3-xlib/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=py-xlib
+_pkgname=python-xlib
+pkgver=0.20
+pkgrel=2
+pkgdesc="A fully functional X client library for Python programs"
+url="https://github.com/python-xlib/python-xlib"
+arch="noarch"
+license="LGPL-2.0"
+depends="py-six"
+checkdepends="xvfb"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="${pkgname/py-/py3-}:_py3 ${pkgname/py-/py2-}:_py2"
+source="https://github.com/$_pkgname/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ Xvfb :1 &
+ export DISPLAY=:1
+ python2 setup.py test
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="7717832a8da13cde236143f4fc1b849b02e306b59cad6146db0a2fc6d19e9a9f60604110cceadd9a9041e013dcc4d67dcb1c2629e0ca44f9c69ed91d2a1c5adf python-xlib-0.20.tar.bz2"