aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-xlwt
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-26 09:55:10 +0200
committerprspkt <prspkt@protonmail.com>2019-03-26 10:25:29 +0200
commitc06984f22d95f3c857ead7ef5683da4e58f63a3d (patch)
treeb597f4c41d4b2b8de329438b4db524f980192efa /testing/py3-xlwt
parent2e508d7528ca4d9496f05d7f453cbd17dbb80f9d (diff)
downloadaports-c06984f22d95f3c857ead7ef5683da4e58f63a3d.tar.bz2
aports-c06984f22d95f3c857ead7ef5683da4e58f63a3d.tar.xz
testing/py-xlwt: upgrade to python3
Diffstat (limited to 'testing/py3-xlwt')
-rw-r--r--testing/py3-xlwt/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-xlwt/APKBUILD b/testing/py3-xlwt/APKBUILD
new file mode 100644
index 0000000000..f6f3a779f2
--- /dev/null
+++ b/testing/py3-xlwt/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-xlwt
+_pkgname=xlwt
+pkgver=0.7.5
+pkgrel=0
+pkgdesc="A library to create spreadsheet files"
+url="http://pypi.python.org/pypi/xlwt/"
+arch="noarch"
+license="BSD"
+provides="py-xlwt" # for backwards compatibility
+replaces="py-xlwt=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+depends_dev=""
+makedepends="py3-setuptools python3-dev"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="d385c36c80002998891dd93d4ebcdd962239463ee089965961d3b8955d4783bbcdec96920891a252ee6cb076eab6b13ffad83e7758c179dcbc684e82fa8dfe35 xlwt-0.7.5.tar.gz"