aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-xmldiff
diff options
context:
space:
mode:
authorSascha Brawer <sascha@brawer.ch>2020-03-07 09:22:03 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-07 09:43:05 +0100
commit43a4744a19745adcc3efee9a8e30404bd5cb8789 (patch)
tree446092c56d4b420fb7f09baf5f193bd452d2afda /testing/py3-xmldiff
parentcc09fce7f71600af877ef9775671922c6bbb0645 (diff)
downloadaports-43a4744a19745adcc3efee9a8e30404bd5cb8789.tar.bz2
aports-43a4744a19745adcc3efee9a8e30404bd5cb8789.tar.xz
testing/py3-xmldiff: new aport
https://github.com/Shoobx/xmldiff Creates diffs of XML files
Diffstat (limited to 'testing/py3-xmldiff')
-rw-r--r--testing/py3-xmldiff/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-xmldiff/APKBUILD b/testing/py3-xmldiff/APKBUILD
new file mode 100644
index 0000000000..b6ddb8d1b1
--- /dev/null
+++ b/testing/py3-xmldiff/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Sascha Brawer <sascha@brawer.ch>
+# Maintainer: Sascha Brawer <sascha@brawer.ch>
+pkgname=py3-xmldiff
+_pyname=xmldiff
+pkgver=2.4
+pkgrel=0
+pkgdesc="Creates diffs of XML files"
+url="https://github.com/Shoobx/xmldiff"
+arch="noarch"
+license="MIT"
+depends="python3 py3-lxml py3-six"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/x/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="cc96c0d46d251ce1cf664c86f8fc0cc8fef67de6d0472415ae755e32cb86f21495dd144b5ecebba11820297a3f3cae8067c8d3b25b3107a8134b6ea641f2fc07 xmldiff-2.4.tar.gz"