aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-xmltodict
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-29 21:03:15 -0300
committerprspkt <prspkt@protonmail.com>2019-06-06 00:34:47 +0300
commit7fd572e1f7325b814a4bc9bdc88525d008ec52f8 (patch)
treec6e04f90fc59765e3dbe5f616c5360542b4b9807 /testing/py3-xmltodict
parent4625c5bea508584caecd02d0eb842f459d9b97e3 (diff)
downloadaports-7fd572e1f7325b814a4bc9bdc88525d008ec52f8.tar.bz2
aports-7fd572e1f7325b814a4bc9bdc88525d008ec52f8.tar.xz
testing/py3-xmltodict: upgrade to 0.12.0
Diffstat (limited to 'testing/py3-xmltodict')
-rw-r--r--testing/py3-xmltodict/APKBUILD53
1 files changed, 19 insertions, 34 deletions
diff --git a/testing/py3-xmltodict/APKBUILD b/testing/py3-xmltodict/APKBUILD
index a5ceff929c..df822ae1e4 100644
--- a/testing/py3-xmltodict/APKBUILD
+++ b/testing/py3-xmltodict/APKBUILD
@@ -1,46 +1,31 @@
-# Maintainer:
-pkgname=py-xmltodict
-pkgver=0.11.0
-pkgrel=1
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-xmltodict
+_realname=xmltodict
+pkgver=0.12.0
+pkgrel=0
pkgdesc="an xmltodict implementation"
url="https://pypi.python.org/pypi/xmltodict/"
arch="noarch"
-license="BSD"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-xmltodict:py2 py3-xmltodict:py3"
-source="https://files.pythonhosted.org/packages/source/x/xmltodict/xmltodict-$pkgver.tar.gz"
-builddir="$srcdir/xmltodict-$pkgver"
+license="MIT"
+makedepends="py3-setuptools"
+checkdepends="py3-nose py3-coverage"
+source="$pkgname-$pkgver.tar.gz::https://github.com/martinblech/$_realname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+replaces="py-xmltodict" # Backward compat
+provides="py-xmltodict=$pkgver-r$pkgrel" # Backward compat
build() {
- cd "$_builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-py2() {
- cd "$builddir"
- _py python2
+check() {
+ nosetests
}
-py3() {
- cd "$builddir"
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="d42ef146a40f386a5389958f890605c560ce9db2da4447099b8725edc1998339b77ea732576fc7e77fbe5a755a2dc3239dfae4a82fc6593c5f977145ab445295 xmltodict-0.11.0.tar.gz"
+sha512sums="baab65299134f3daec05e6c1d9cbb80343cc89f7d1fee2fd3be2bba0bc5c7dd78dcc72abd8cb721edd0c9504eab2d9e4135618237b54a85809dc0cf42b6f7616 py3-xmltodict-0.12.0.tar.gz"