aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zeroconf
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-28 00:51:58 +0300
committerprspkt <prspkt@protonmail.com>2019-05-28 00:58:08 +0300
commiteea011f372148f38eb895e78127ff0de4dc04522 (patch)
treeb4a035377574a9d780f087f561cb4f240366c593 /testing/py3-zeroconf
parentba55bcab244b5909eed320d0750d51841197d2b6 (diff)
downloadaports-eea011f372148f38eb895e78127ff0de4dc04522.tar.bz2
aports-eea011f372148f38eb895e78127ff0de4dc04522.tar.xz
testing/py-zeroconf: upgrade to python3
Diffstat (limited to 'testing/py3-zeroconf')
-rw-r--r--testing/py3-zeroconf/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-zeroconf/APKBUILD b/testing/py3-zeroconf/APKBUILD
new file mode 100644
index 0000000000..866025a103
--- /dev/null
+++ b/testing/py3-zeroconf/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-zeroconf
+_pkgname=zeroconf
+pkgver=0.21.3
+pkgrel=1
+pkgdesc="A Python implementation of multicast DNS service discovery"
+url="https://github.com/jstasiak/python-zeroconf"
+arch="noarch"
+license="LGPL-2.0-or-later"
+# Tests require netlink support which is no present in AL
+replaces="py-zeroconf" # for backwards compatibility
+provides="py-zeroconf=$pkgver-r$pkgrel" # for backwards compatibility
+options="!check"
+depends="py3-six py3-netifaces"
+makedepends="py3-setuptools python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e7634d470bf382834f3c03f65797b64a8ccf8bebbf711f47186f7a57077b017bbb811d22d43d69ca016166bc547fb450ac889a73fd118c3ed23208a3007c8f63 zeroconf-0.21.3.tar.gz"