aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zipp
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 02:46:34 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 02:46:34 -0300
commitedb145472907ad1d7b62b3f59a4796867be42da1 (patch)
treec97cf211f4fd4ed48cd93085d5a56cdc22b85ea0 /testing/py3-zipp
parentdd4ab1fedd57f032aa003934ffdb5aa7499755b3 (diff)
downloadaports-edb145472907ad1d7b62b3f59a4796867be42da1.tar.bz2
aports-edb145472907ad1d7b62b3f59a4796867be42da1.tar.xz
testing/py3-zipp: drop py2
Diffstat (limited to 'testing/py3-zipp')
-rw-r--r--testing/py3-zipp/APKBUILD35
1 files changed, 7 insertions, 28 deletions
diff --git a/testing/py3-zipp/APKBUILD b/testing/py3-zipp/APKBUILD
index af22e85acf..fc751cfea7 100644
--- a/testing/py3-zipp/APKBUILD
+++ b/testing/py3-zipp/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: prspkt <prspkt@protonmail.com>
# Maintainer: prspkt <prspkt@protonmail.com>
-pkgname=py-zipp
+pkgname=py3-zipp
_pkgname=zipp
pkgver=0.6.0
pkgrel=0
@@ -8,45 +8,24 @@ pkgdesc="Pathlib-compatible object wrapper for zip files"
url="https://github.com/jaraco/zipp"
arch="noarch"
license="MIT"
-depends="py-more-itertools py-six"
-makedepends="py2-setuptools py3-setuptools"
-checkdepends="py2-contextlib2 py2-pathlib2 py2-unittest2"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-more-itertools py3-six"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-zipp" # Backwards compatibility
+provides="py-zipp=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="18bef5aa3388ab3901bf08888127fc9cc17d8972a52f23ccf9a8035f09ee5598e17ddff833a10b81b2118461e0c517e88413518736763425a728cd0b19cc2052 zipp-0.6.0.tar.gz"