aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zipp
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 15:38:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 02:46:29 -0300
commitdd4ab1fedd57f032aa003934ffdb5aa7499755b3 (patch)
treecf8d4f7c6cb1edd850ecbf4cb8d7d6ee8fa4021e /testing/py3-zipp
parent1c354778159c3980bcdd1c5a1314951aad6a15f7 (diff)
downloadaports-dd4ab1fedd57f032aa003934ffdb5aa7499755b3.tar.bz2
aports-dd4ab1fedd57f032aa003934ffdb5aa7499755b3.tar.xz
testing/py3-zipp: rename from py-zipp
Diffstat (limited to 'testing/py3-zipp')
-rw-r--r--testing/py3-zipp/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/py3-zipp/APKBUILD b/testing/py3-zipp/APKBUILD
new file mode 100644
index 0000000000..af22e85acf
--- /dev/null
+++ b/testing/py3-zipp/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py-zipp
+_pkgname=zipp
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="Pathlib-compatible object wrapper for zip files"
+url="https://github.com/jaraco/zipp"
+arch="noarch"
+license="MIT"
+depends="py-more-itertools py-six"
+makedepends="py2-setuptools py3-setuptools"
+checkdepends="py2-contextlib2 py2-pathlib2 py2-unittest2"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ python2 setup.py test
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="18bef5aa3388ab3901bf08888127fc9cc17d8972a52f23ccf9a8035f09ee5598e17ddff833a10b81b2118461e0c517e88413518736763425a728cd0b19cc2052 zipp-0.6.0.tar.gz"