aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zope-exceptions
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:58:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 07:09:11 -0300
commitefa454f94cc9bdd0e2a0859723b7c37600cadfff (patch)
tree30c0452bd21938cd07ff4d7a296b341fcfe50e57 /testing/py3-zope-exceptions
parent0ea15ac8d8957bdc5960d344edfdf568534ae2fb (diff)
downloadaports-efa454f94cc9bdd0e2a0859723b7c37600cadfff.tar.bz2
aports-efa454f94cc9bdd0e2a0859723b7c37600cadfff.tar.xz
testing/py3-zope-exceptions: new aport
https://github.com/zopefoundation/zope.exceptions Zope Exceptions
Diffstat (limited to 'testing/py3-zope-exceptions')
-rw-r--r--testing/py3-zope-exceptions/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-zope-exceptions/APKBUILD b/testing/py3-zope-exceptions/APKBUILD
new file mode 100644
index 0000000000..3ee4c41b59
--- /dev/null
+++ b/testing/py3-zope-exceptions/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-zope-exceptions
+_pkgname=zope.exceptions
+pkgver=4.3
+pkgrel=0
+pkgdesc="Zope Exceptions"
+# Cyclic dep zope.testrunner needs zope.exceptions to run, but zope.exceptions
+# needs zope.testrunner on its test dependencies
+options="!check"
+url="https://github.com/zopefoundation/zope.exceptions"
+arch="noarch"
+license="ZPL-2.1"
+depends="python3 py3-zope-interface py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="348c8edb0246bb2035ca5c1bcfaca7d3be2525157e2c9267a59a061c8ba749b364428e3d6a3aa3f967306abd0a319e4d6fa935b7fc35fff3bb53960015505695 zope.exceptions-4.3.tar.gz"