aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zope-schema
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:45:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:45:10 -0300
commiteeb3d86ff9c183dc335a06b7d8fc089b05999c65 (patch)
tree5f7519106ce0643fbf1b35df2766bedc46467436 /testing/py3-zope-schema
parent7a2aa3d68831381185b0594837977cbd1d1350e2 (diff)
downloadaports-eeb3d86ff9c183dc335a06b7d8fc089b05999c65.tar.bz2
aports-eeb3d86ff9c183dc335a06b7d8fc089b05999c65.tar.xz
testing/py3-zope-schema: new aport
https://github.com/zopefoundation/zope.schema zope.interface extension for defining data schemas
Diffstat (limited to 'testing/py3-zope-schema')
-rw-r--r--testing/py3-zope-schema/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-zope-schema/APKBUILD b/testing/py3-zope-schema/APKBUILD
new file mode 100644
index 0000000000..14a39e0c5e
--- /dev/null
+++ b/testing/py3-zope-schema/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-zope-schema
+_pkgname=zope.schema
+pkgver=4.9.3
+pkgrel=0
+pkgdesc="zope.interface extension for defining data schemas"
+options="!check" # Tests require 'zope.testing', 'zope.testruner' and 'zope.i18nmessageid'
+url="https://github.com/zopefoundation/zope.schema"
+arch="noarch"
+license="ZPL-2.1"
+depends="py3-setuptools py3-zope-interface py3-zope-event"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="63cdf431ba2aa79eb5771f99cf0a60932182edae00a63873f96cc02c70f826d23c72ecabd736d0f6439d63af900b4ee2c05246eabe0b1689b01bc15a09648504 zope.schema-4.9.3.tar.gz"