aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zope-testrunner
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 07:00:42 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 07:09:11 -0300
commit8f2e297258f2dea4a61c3ba35fdfd26ec8ca1799 (patch)
treef3111a1343c28e4ab4d867569733abd32f5f6ddd /testing/py3-zope-testrunner
parentefa454f94cc9bdd0e2a0859723b7c37600cadfff (diff)
downloadaports-8f2e297258f2dea4a61c3ba35fdfd26ec8ca1799.tar.bz2
aports-8f2e297258f2dea4a61c3ba35fdfd26ec8ca1799.tar.xz
testing/py3-zope-testrunner: new aport
https://github.com/zopefoundation/zope.testrunner Zope testrunner script
Diffstat (limited to 'testing/py3-zope-testrunner')
-rw-r--r--testing/py3-zope-testrunner/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-zope-testrunner/APKBUILD b/testing/py3-zope-testrunner/APKBUILD
new file mode 100644
index 0000000000..c1bce2d2d3
--- /dev/null
+++ b/testing/py3-zope-testrunner/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-zope-testrunner
+_pkgname=zope.testrunner
+pkgver=5.0
+pkgrel=0
+pkgdesc="Zope testrunner script"
+options="!check" # Fails to run
+url="https://github.com/zopefoundation/zope.testrunner"
+arch="all"
+license="ZPL-2.1"
+depends="python3 py3-setuptools py3-six py3-zope-exceptions py3-zope-interface"
+makedepends="python3-dev"
+checkdepends="py3-zope-testing"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9422b7ce945f076f6351c3cbd9db799ac892e094038c305c53ffc53c5f5cbe0317fb0e2e84777613be640b42fba37316ff4bb7fca1821c853ad40b6c31ed7762 zope.testrunner-5.0.tar.gz"